Author Topic: [SCREENPLAY] All are dark  (Read 744 times)

MiKL28fr

  • Worker
  • Posts: 2
    • View Profile
[SCREENPLAY] All are dark
« on: 21 February 2019, 13:34:31 »
Hello everyone,

I'm new here.
I'm french, so excuse me for my writer expression.

I installed MegaGlest today. First in the version 3.7.1 since the official package for ubuntu.
second, the version 3.13.0 with the .run download since this web site.

In those two versions, I can navigate to the menu and configurations.
I can run the tutorial, but all texture of the screenplay are dark, excepted a green cercle and a blue arrow when i find the mainTeepee.
Excepted, the begins messages, menu, border of map and a red zone, resource, and icon of Worker for this "generation".

I run on LinuxMint 17.3 32bits (Ubuntu 14.04.3)
Desktop : Cinnamon 2.8.8
Kernel linux : 3.19.0-32-generic
Processor : AMD Athlon 64 X2 4200+ 2Ghz
Memory: 3Go DDR
Graphic Card: GeForce 7900 GT/CTO 256 (processor G71), with driver open source 1.0.10-1ubuntu2
openGl : 2.1 Mesa 10.5.9

Where is the problem ?
Can you help me ?


tomreyn

  • Local Moderator
  • Airship
  • ********
  • Posts: 2,764
    • View Profile
    • MegaGlest - the free and open source cross platform 3D real-time strategy game
Re: [SCREENPLAY] All are dark
« Reply #1 on: 21 February 2019, 16:04:50 »
The open source Nvidia driver, nouveau, is unfortunately very lacking since this company does not make an open source graphics driver, and does not make enough documentation available under terms which would allow to produce an open driver either. This also makes it more and more difficult to make ti work well with Linux. AMD and Intel are doing better there.
Based on the findings you report I am quite sure that what you are seeing is a result of the deficiencies of this driver. You should probbaly try a newer OS (you run Linux 3.19, while 5.0 is going to be released shortly) and dristribution release, which bears the chance of getting newer nouveau versions, and thus new bug fixes.

Ubuntu (which you are not using, you are using a derivative) does make newer MegaGlest packages available for all releases but Ubuntu 14.04 "Trusty Tahr" (which looses support in a month): https://packages.ubuntu.com/search?keywords=megaglest
atibox: Ryzen 1800X (8 cores @3.6GHz), 32 GB RAM, MSI Radeon RX 580 Gaming X 8G, PCI subsystem ID [1462:3417], (Radeon RX 580 chipset, POLARIS10) @3440x1440; latest stable Ubuntu release, (open source) radeon (amdgpu) / mesa video driver
atibox (old): Core2Quad Q9400 (4 cores @2.66GHz), 8 GB RAM, XFX HD-467X-DDF2, PCI subsystem ID [1682:2931], (Radeon HD 4670, RV730 XT) @1680x1050; latest stable Ubuntu release, (open source) radeon / mesa video driver
notebook: HP envy13d020ng
internet access: VDSL2+

· · · How YOU can contribute to MG · Latest development snapshot · How to build yourself · Megapack techtree · Currently hosted MG games · · ·

andy_5995

  • Moderator
  • Ornithopter
  • ********
  • Posts: 454
  • Debian Linux user
    • View Profile
    • Andy Alt's home page
Re: [SCREENPLAY] All are dark
« Reply #2 on: 21 February 2019, 16:49:11 »
I've had an Intel card for a while and haven't used the nouveau driver for years. Recently I got a GEFORCE GTX 1050 and installed the package "nvidia-driver" on Debian stretch and buster. As Ubuntu is Debian-based, there may be a similarly-named package. You might want to try that before you upgrade your operating system.

MiKL28fr

  • Worker
  • Posts: 2
    • View Profile
Re: [SCREENPLAY] All are dark
« Reply #3 on: 21 February 2019, 17:22:08 »
Thank you for your answers.

I'll try update NOUVEAU in a newer version.
I don't use the Nvidia drivers, I still have a serious crash of the server X.

Upgrade my OS to the similary Ubuntu 18.04 it's possible linuxmint 19)
But I don't know if my PC it's most powerfull.

andy_5995

  • Moderator
  • Ornithopter
  • ********
  • Posts: 454
  • Debian Linux user
    • View Profile
    • Andy Alt's home page
Re: [SCREENPLAY] All are dark
« Reply #4 on: 21 February 2019, 17:40:18 »
I'm sorry to hear you're having problems. As for system requirements, they are listed here. I've been using MG on Intel 1st Gen ( which is less than "Sandy Bridge"/2nd generation listed in the requirements) for 3 years. It ran fine except for some lag when there are a lot of units in the game, but that was caused by my Intel integrated GPU, and now works fine with my 1050.

According to this comparison chart, your PC probably doesn't meet the recommended system requirements, but that doesn't mean it won't be able to run MegaGlest.