Author Topic: Displays game off center in full screen  (Read 7970 times)

drutis

  • Guest
Displays game off center in full screen
« on: 27 January 2010, 13:48:39 »
Works fine in windowed mode, but I prefer full screen.

CPU:AMD Athlon 64
GPU:ATI HD 4650 600M 1GB DDR2  ???
Driver: ATI Catalyst 9.12
Screen rez: 1280x720, 75hz
OS: XP 32

 I don't know much about tech stuff. If there is any other info I can provide, let me know pls.

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Displays game off center in full screen
« Reply #1 on: 28 January 2010, 00:33:12 »
Well, that is a very odd, very rare resolution. In fact, so rare I've never seen it before. You might have to set the resolution in the ini (in the same folder you installed glest to, titled 'glest.ini'. Open it in notepad or your favorite plain text editor).

Look for lines with screen height and screen width, and change the height to be 720 and the width to be 1280. Hopefully that will fix it.

If not, talk to me again. If too complex to understand what to do, tell me and I'll dumb it down.
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

drutis

  • Guest
Re: Displays game off center in full screen
« Reply #2 on: 28 January 2010, 13:12:22 »
Well, that is a very odd, very rare resolution. In fact, so rare I've never seen it before. You might have to set the resolution in the ini (in the same folder you installed glest to, titled 'glest.ini'. Open it in notepad or your favorite plain text editor).

Look for lines with screen height and screen width, and change the height to be 720 and the width to be 1280. Hopefully that will fix it.

If not, talk to me again. If too complex to understand what to do, tell me and I'll dumb it down.

Ok, this is what my screen rez IS set to. I guess I had height and width backwards in my post above. As I said I am not a techie :P

Just to clear it up my screen rez is: Height 720, Width 1280.

Thanks for the prompt reply :)

-Archmage-

  • Moderator
  • Dragon
  • ********
  • Posts: 5,886
  • Make it so.
    • View Profile
    • My Website
Re: Displays game off center in full screen
« Reply #3 on: 28 January 2010, 13:24:41 »
Can you set it to a more common resolution?

Like 1024x768?
Egypt Remastered!

Proof: Owner of glest@mail.com

drutis

  • Guest
Re: Displays game off center in full screen
« Reply #4 on: 28 January 2010, 13:26:23 »
Ok, nevermind. I figured it out.

 It seems that the game simply doesn't like "wide screen" (aka letter box). I set res to 768h x 1024w. it looks a little "fish eyed" but it works.  :)

KeithL

  • Guest
Re: Displays game off center in full screen
« Reply #5 on: 15 September 2010, 03:26:43 »
Let's bump this again. I have the same problem - game is displayed too far to the left in Ubuntu 10.04 (Glest 3.2.2 distro).

I run a nonfree nvidia driver on a 9800GT card. Problem is apparent in every screen resolution from 640x480 to 1920x1200 in full screen mode. No idea how to run this windowed.

Modified glest.ini to each resolution tried - no luck.
Changed glest.ini Windowed parameter to 1, no effect there either.

Am I missing something?

-Archmage-

  • Moderator
  • Dragon
  • ********
  • Posts: 5,886
  • Make it so.
    • View Profile
    • My Website
Re: Displays game off center in full screen
« Reply #6 on: 15 September 2010, 03:31:50 »
It sounds to me like you're editing the wrong ini file...
What's the path of the ini file you're editing?
Egypt Remastered!

Proof: Owner of glest@mail.com

KeithL

  • Guest
Re: Displays game off center in full screen
« Reply #7 on: 15 September 2010, 03:46:36 »
I grabbed this from the package manager. The game and .ini sits in /usr/lib/glest/

-Archmage-

  • Moderator
  • Dragon
  • ********
  • Posts: 5,886
  • Make it so.
    • View Profile
    • My Website
Re: Displays game off center in full screen
« Reply #8 on: 15 September 2010, 03:54:49 »
I don't have the latest Ubuntu, they must've changed some stuff... :look:

Go into your user directory and look for a .glest or .config folder, tell me what you find. ;)
Egypt Remastered!

Proof: Owner of glest@mail.com

KeithL

  • Guest
Re: Displays game off center in full screen
« Reply #9 on: 15 September 2010, 04:06:46 »
Thanks for pointing me in the right direction.

The glest.ini lives off the ~/.config/glest path. I found the script which boosts the files into the user dir (Duh...)

Anyway, modifying the display parameters in ~/.config/glest/glest.ini to match the screen's resolution fixed the problem (and also makes the graphics look a lot sharper).

Thanks again for the help.

-Archmage-

  • Moderator
  • Dragon
  • ********
  • Posts: 5,886
  • Make it so.
    • View Profile
    • My Website
Re: Displays game off center in full screen
« Reply #10 on: 15 September 2010, 04:20:32 »
Thanks for pointing me in the right direction.

The glest.ini lives off the ~/.config/glest path. I found the script which boosts the files into the user dir (Duh...)

Anyway, modifying the display parameters in ~/.config/glest/glest.ini to match the screen's resolution fixed the problem (and also makes the graphics look a lot sharper).

Thanks again for the help.

No problem dude, glad to help! :)
Happy Glesting! :cheesy:
Egypt Remastered!

Proof: Owner of glest@mail.com