Author Topic: Kubuntu Lucid 32bit installer installs fine Game doesn't start though  (Read 3593 times)

ForSSux

  • Guest
Hi there,

I'm running Kubuntu 10.04 Lucid and installed Megaglest 3.3.5 with the installer.
Click or double click didn't started the install though, but opening a terminal and issuning the ./Mega-Glest... works...

But after the install the game doesn't start :-(
I opend a terminal and went to /home/user/Megaglest/bin and started ./glest.bin
forssman@AMD-940-Kubuntu:~/megaglest/bin$ ./glest.bin
./glest.bin: error while loading shared libraries: libxerces-c.so.28: cannot open shared object file: No such file or directory
forssman@AMD-940-Kubuntu:~/megaglest/bin$ ./glest.bin
./glest.bin: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory
forssman@AMD-940-Kubuntu:~/megaglest/bin$ ./glest.bin

the libxerces problem was solved with installing some librarys

Can somebody help me
Kind regards
Guy

-Archmage-

  • Moderator
  • Dragon
  • ********
  • Posts: 5,886
  • Make it so.
    • View Profile
    • My Website
Quote
For trouble with libopenal.so.0 the command is like:
Code: [Select]
ln -s /usr/lib32/libopenal.so.1 <PathToGlestInstallation>/lib/libopenal.so.0

That should do it. :)
Egypt Remastered!

Proof: Owner of glest@mail.com

ForSSux

  • Guest
Thanks for the quick reply....in Lucid the libopenal isn't at /usr/lib32 but at /usr/lib......

Anyway I made the symlink, but got the following error now

forssman@AMD-940-Kubuntu:~$ sudo ln -s /usr/lib/libopenal.so.1 home/forssman/megaglest/lib/libopenal.so.0
ln: aanmaken van symbolische koppeling `home/forssman/megaglest/lib/libopenal.so.0’: Bestand of map bestaat niet
forssman@AMD-940-Kubuntu:~$ sudo ln -s /usr/lib/libopenal.so.1 megaglest/lib/libopenal.so.0
ln: aanmaken van symbolische koppeling `megaglest/lib/libopenal.so.0’: Bestand bestaat al
forssman@AMD-940-Kubuntu:~$ sudo ln -sf /usr/lib/libopenal.so.1 megaglest/lib/libopenal.so.0
forssman@AMD-940-Kubuntu:~$ ./bin/glest.bin
bash: ./bin/glest.bin: Bestand of map bestaat niet
forssman@AMD-940-Kubuntu:~$ ./megaglest/bin/glest.bin
v3.3.5 built: Jul  3 2010 00:24:24 Compiled with GNUC: 40204, STREFLOP enabled.
[2010-07-13 14:54:06] In [glest_game/global/config.cpp::Config Line: 60] cfgFile.first = [glest.ini]
[2010-07-13 14:54:06] In [shared_lib/sources/util/properties.cpp::load Line: 39] path = [glest.ini]
[2010-07-13 14:54:06] In [shared_lib/sources/util/properties.cpp::load Line: 43] path = [glest.ini]
[2010-07-13 14:54:06] In [glest_game/main/main.cpp::handleRuntimeError Line: 73] [Can't open propertyMap file: glest.ini] gameInitialized = 0, program = (nil)
******************************************************
    #2 An error ocurred and Glest will close.
Error msg = [Can't open propertyMap file: glest.ini]

Please report this bug to contact_game@glest.org, attaching the generated glestv3.3.5.dmp file.
******************************************************
START Closing logfiles
END Closing logfiles
 

Kind regards
Guy Forssman

-Archmage-

  • Moderator
  • Dragon
  • ********
  • Posts: 5,886
  • Make it so.
    • View Profile
    • My Website
Quote
Error msg = [Can't open propertyMap file: glest.ini]

This sounds like permission trouble...........
Make sure that your MG folder has it's permissions set so that anyone can do anything, then the program shouldn't give that error message.

I'm assuming that this: "Can't open propertyMap file: glest.ini", is an approximate translation(from Dutch?) of this: "Bestand of map bestaat niet"... Because this: "Bestand of map bestaat niet", translates too: "Truce or file do not exists".......
Egypt Remastered!

Proof: Owner of glest@mail.com

ForSSux

  • Guest
Hi me back again

forssman@AMD-940-Kubuntu:~$ sudo chmod 777 -R megaglest
forssman@AMD-940-Kubuntu:~$ ./megaglest/bin/glest.bin
v3.3.5 built: Jul  3 2010 00:24:24 Compiled with GNUC: 40204, STREFLOP enabled.
[2010-07-13 15:53:55] In [glest_game/global/config.cpp::Config Line: 60] cfgFile.first = [glest.ini]
[2010-07-13 15:53:55] In [shared_lib/sources/util/properties.cpp::load Line: 39] path = [glest.ini]
[2010-07-13 15:53:55] In [shared_lib/sources/util/properties.cpp::load Line: 43] path = [glest.ini]
[2010-07-13 15:53:55] In [glest_game/main/main.cpp::handleRuntimeError Line: 73] [Can't open propertyMap file: glest.ini] gameInitialized = 0, program = (nil)
******************************************************
    #2 An error ocurred and Glest will close.
Error msg = [Can't open propertyMap file: glest.ini]

furthemore bestand (Dutch) = file (English) and map = Directory

thanks for helping me
Guy

softcoder

  • MegaGlest Team
  • Battle Machine
  • ********
  • Posts: 2,238
    • View Profile
You need to run the startup script in the megaglest root folder:

./glest

NOT glest.bin

Thanks

ForSSux

  • Guest
Thank you,

This indeed starts the game and it runs fine.

Guy Forssman

 

anything