Author Topic: AI doesn't reproduce destroyed building (barrack)  (Read 2406 times)

oqhkasdhfoquzwer

  • Guest
AI doesn't reproduce destroyed building (barrack)
« on: 15 January 2011, 00:37:12 »
Since the AI is far too difficult for human players I got used to play in teams - two AIs on on side, one AI and me on the other side.
Once my buddy lost every type of building but the castle, the farm and some defence towers. I rushed to his base and defeated the opponents there. After that, my buddy AI continued to harvest everything needed over a long period of time but did not build a new barrack or any other building.
From my point of view this is a bug.
Anyone here who made the same experience?
Cheers,
oqhkasdhfoquzwer

ultifd

  • Airship
  • ********
  • Posts: 4,443
  • The Glest Video Guy :) The one and only. :P
    • View Profile
    • My Youtube Channel
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #1 on: 15 January 2011, 00:39:01 »
Hmm...I guess this could be classified as an "AI bug".
What version of Glest are you using? MegaGlest? GAE? Original Glest? Is it always reproduceable? Certain map/setup?
Thanks.

oqhkasdhfoquzwer

  • Guest
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #2 on: 15 January 2011, 00:45:46 »
Sorry I forgot that:
Glest 3.2.2 (vanilla)
Tile set : Forrest
Map: Four rivers
Player 1 : Human, tech, Team 1
Player 2 : CPU, tech, Team 1
Player 3 : CPU, magic, Team 2
Player 4 : CPU, magic, Team 2
Techtree: Magitech

I have not tried to reproduce that yet. But my pal definetly had enough ressources to build something.

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #3 on: 15 January 2011, 08:01:46 »
Please note: Vanilla Glest has been out of developement for over a year and will not have any more releases. Unless this bug also appears on GAE or MG, this issue is void (and I would recommend you move to one of those branches).
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

Gabbe

  • Guest
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #4 on: 15 January 2011, 09:34:18 »
You can find MegaGlest (MG) and GAE on the forum main board. Hope you will download it and play with us ;)

Cygal

  • Guest
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #5 on: 15 January 2011, 10:36:41 »
I don't think it's fixed in MegaGlest either, due to the way the AI works: there is no "expand" rule, so there is no "build another base" rule. I'll try to come up with a fix in MG, but this is part of larger problems (the expand one, for example).

Psychedelic_hands

  • Guest
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #6 on: 15 January 2011, 12:37:26 »
I've notice this before too.

GAE is going to be upgrading the A.I pretty soon, actually I think Silnarm said he started work on it awhile ago... So yeah, hopefully it might get done soon ;)

Cygal

  • Guest
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #7 on: 15 January 2011, 15:26:26 »
Oh, really? This would be nice to know what he is planning, because I'm actually trying to do the same. I am not part of the MegaGlest team, but it looked like they agreed at my proposed changes.

I'm sure the AI code is not that far away between the two engines, and as it is nicely decoupled from other things, a contribution would be possible.

Psychedelic_hands

  • Guest
Re: AI doesn't reproduce destroyed building (barrack)
« Reply #8 on: 15 January 2011, 15:48:11 »
I know he's doing something that should make it way easier, but it's not my news to tell sorry. So ask him yourself.  :angel: