Author Topic: Forums moved to forum.megaglest.org  (Read 2583 times)

tomreyn

  • MegaGlest Team
  • Airship
  • ********
  • Posts: 2,764
    • View Profile
    • MegaGlest - the free and open source cross platform 3D real-time strategy game
Forums moved to forum.megaglest.org
« on: 21 March 2013, 00:58:23 »
Hi all,

as you may have notivied the forums have moved to a new location: https://forum.megaglest.org

The Glest team has kindly passed over management of these forums to the MegaGlest team (and set links and redirects on glest.org), acknowledging that MegaGlest is now the most active and likeable continuation of the Glest legacy. (The latter is my personal interpretation.)

We appreciate the trust the Glest team puts in us by passing the management on this central community hub on to the MegaGlest team (and Omega, who has kindly offered to continue to manage the board), and are looking forward to creating the future *Glest* forums, by means of restructuring this resource to make it even more usable.

We will happily continue to cooperate with and host the other Glest forks here, in fact we'll be happy to grat you access to your subforums by means of a hostname of your choice - please get in touch by e-mail or IRC.

Your feedback on technical and privacy issues is also very welcome, please post here or mail webmaster at megaglest dot org.

For a small technical update, I'd like to point out that the forums are now SSL only, this will prevent spoofing on your forum passwords. So now is actually a good time to set a new password (something one should be doing every 6-12 months anyways). When you do, please make it at least 8 characters long, consisting of all of letters, numbers and special characters, and make sure it's not a term found in a  dictionary or a name (doing so is ok when you use a full phrase). We'll get in touch soon to discuss (in more detail) what today's changes mean for forum account holders.

Thanks for your time,

Tom
atibox: Ryzen 1800X (8 cores @3.6GHz), 32 GB RAM, MSI Radeon RX 580 Gaming X 8G, PCI subsystem ID [1462:3417], (Radeon RX 580 chipset, POLARIS10) @3440x1440; latest stable Ubuntu release, (open source) radeon (amdgpu) / mesa video driver
atibox (old): Core2Quad Q9400 (4 cores @2.66GHz), 8 GB RAM, XFX HD-467X-DDF2, PCI subsystem ID [1682:2931], (Radeon HD 4670, RV730 XT) @1680x1050; latest stable Ubuntu release, (open source) radeon / mesa video driver
notebook: HP envy13d020ng
internet access: VDSL2+

· · · How YOU can contribute to MG · Latest development snapshot · How to build yourself · Megapack techtree · Currently hosted MG games · · ·

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Forums moved to forum.megaglest.org
« Reply #1 on: 21 March 2013, 02:20:45 »
To increase emphasis on the forums on megaglest.org, could the link to the forums be moved up from the sidebar to the header? To make room, it could be switched with contact.
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Forums moved to forum.megaglest.org
« Reply #2 on: 21 March 2013, 04:10:08 »

Testing tags


(ensuring mods installed correctly)



Wikipedia link: [wiki]MegaGlest[/wiki]

(click to show/hide)

Inline preformatted text (for code and all)

FormattedTable
BadadeeDumdum
BadadeeDumdum

https://www.youtube.com/watch?v=5tiQH7UV-5Y

Float right
Float left



This page's code:
Code: [Select]
[h1]Testing tags[/h1]
[h2](ensuring mods installed correctly)[/h2]

Wikipedia link: [wiki]MegaGlest[/wiki]

[spoiler]Spoiler[/spoiler]

[tt]Inline preformatted text (for code and all)[/tt]

[ftable]
[ftr]
[fth]Formatted[/fth]
[fth]Table[/fth]
[/ftr]
[ftr]
[ftd]Badadee[/ftd]
[ftd]Dumdum[/ftd]
[/ftr]
[ftr]
[ftd]Badadee[/ftd]
[ftd]Dumdum[/ftd]
[/ftr]
[/ftable]

[youtube]5tiQH7UV-5Y[/youtube]

[float=right]Float right
[img]http://megaglest.org/uploads/megaglest2011/logo/logo.png[/img][/float]
[float=left]Float left
[img]http://megaglest.org/uploads/megaglest2011/logo/logo.png[/img][/float]

Really need to implement a BBCode equivalent of <br style="clear: both" />... The horizontal rule ([hr]) now breaks past floating elements.

Smilies test:  :) :( :D ;D :O ;) :| :o ::) :confused: :-\ :P 8) :-[ :-X :-* :angel: :'( :look: :scared: >:( :bomb: :thumbup: :thumbdown: :archer: :swordman: :dead: :zzz: :silence: :green: :cheesy: :scientist: :wicked:
« Last Edit: 21 March 2013, 17:31:29 by Omega »
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

GunChleoc

  • Horseman
  • ****
  • Posts: 202
    • View Profile
    • Fòram na Gàidhlig
Re: Forums moved to forum.megaglest.org
« Reply #3 on: 21 March 2013, 08:43:57 »
So that's what the maintenance mode was all about... I hope the move went smoothly. I've done a few in my lifetime and these things can be a bloomin' nightmare.

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Forums moved to forum.megaglest.org
« Reply #4 on: 21 March 2013, 08:48:32 »
I hope the move went smoothly. I've done a few in my lifetime and these things can be a bloomin' nightmare.
We screwed up to the point at which we had to restore some files from the originals, but in the end, we got a working board.
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

GunChleoc

  • Horseman
  • ****
  • Posts: 202
    • View Profile
    • Fòram na Gàidhlig
Re: Forums moved to forum.megaglest.org
« Reply #5 on: 21 March 2013, 11:20:00 »
BTW I noticed that it's hard to distinguish "new" from the thread title in the thread list. Maybe a graphic is missing?

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Forums moved to forum.megaglest.org
« Reply #6 on: 21 March 2013, 11:24:46 »
Yeah, I've noticed that. I also know exactly how to fix it, but the easiest method would require Tom to make a copy of a specific folder, so it'll wait for a moment to solve.
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

josepzin

  • Draco Rider
  • *****
  • Posts: 268
    • View Profile
    • José Zanni blog
Re: Forums moved to forum.megaglest.org
« Reply #7 on: 21 March 2013, 11:41:25 »
The migration has went very smoth, good luck boys!!! :)
::. RetroInvaders .::::. My web .::

MuwuM

  • Ornithopter
  • *****
  • Posts: 426
  • No Game without Move(ment)
    • View Profile
    • MuwuM - Lexicons
Re: Forums moved to forum.megaglest.org
« Reply #8 on: 21 March 2013, 11:51:54 »
could you enable the redirection to keep the query string? it would help very much for old links!

Edit: Is there a way to display the connected profiles (of social networks) on the profile page?

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Forums moved to forum.megaglest.org
« Reply #9 on: 21 March 2013, 12:39:18 »
could you enable the redirection to keep the query string? it would help very much for old links!
This is already in place. The URL https://forum.megaglest.org/index.php?topic=8942.msg87108#msg87108 should point to https://forum.megaglest.org/index.php?topic=8942.msg87108#msg87108. Do note the difference in subdomain (glest.org versus forum.megaglest.org) and protocol (HTTP versus HTTPS).

Edit: Is there a way to display the connected profiles (of social networks) on the profile page?
Can you elaborate on what you mean by this? Do you mean you want the profile to have icons and a link to social sites like Skype and Facebook? We previously had a mod that added Skype and GTalk support to the existing ICQ, AIM, MSN, and YIM fields, but it started acting up after moving the boards. I'm planning to take a closer look at similar mods later, or I'll make on myself if necessary.
« Last Edit: 6 April 2016, 19:59:00 by filux »
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

MuwuM

  • Ornithopter
  • *****
  • Posts: 426
  • No Game without Move(ment)
    • View Profile
    • MuwuM - Lexicons
Re: Forums moved to forum.megaglest.org
« Reply #10 on: 21 March 2013, 13:13:06 »
could you enable the redirection to keep the query string? it would help very much for old links!

This is already in place. The URL https://forum.megaglest.org/index.php?topic=8942.msg87108#msg87108 should point to https://forum.megaglest.org/index.php?topic=8942.msg87108#msg87108. Do note the difference in subdomain (glest.org versus forum.megaglest.org) and protocol (HTTP versus HTTPS).

Does this also work for the WAP2 tag (Link on the bottom)
Edit: Is there a way to display the connected profiles (of social networks) on the profile page?
Can you elaborate on what you mean by this? Do you mean you want the profile to have icons and a link to social sites like Skype and Facebook? We previously had a mod that added Skype and GTalk support to the existing ICQ, AIM, MSN, and YIM fields, but it started acting up after moving the boards. I'm planning to take a closer look at similar mods later, or I'll make on myself if necessary.

Yes I think about such icons and links to the pages I connected my board account with.
« Last Edit: 6 April 2016, 19:58:28 by filux »

Omega

  • MegaGlest Team
  • Dragon
  • ********
  • Posts: 6,167
  • Professional bug writer
    • View Profile
    • Personal site
Re: Forums moved to forum.megaglest.org
« Reply #11 on: 21 March 2013, 13:30:59 »
Does this also work for the WAP2 tag (Link on the bottom)
Technically, yes, but for some reason, the semicolon in the link is converted to an entity and thus, you end up on the regular version of the board instead of the WAP2 version. However, I don't recall ever seeing anyone use WAP2 links before (they're meant for mobile usage). The links in the actual software are relative, so don't depend on the host. Only links that come from external source (for example, one that I paste here or is on another site) will be redirected. Is that going to be problematic?

Yes I think about such icons and links to the pages I connected my board account with.
I hope to have such a feature available in the future.
Edit the MegaGlest wiki: http://docs.megaglest.org/

My personal projects: http://github.com/KatrinaHoffert

MuwuM

  • Ornithopter
  • *****
  • Posts: 426
  • No Game without Move(ment)
    • View Profile
    • MuwuM - Lexicons
Re: Forums moved to forum.megaglest.org
« Reply #12 on: 21 March 2013, 14:05:25 »
Quote
Is that going to be problematic?

...I have to replace all the links on my phone :(


ElimiNator

  • Airship
  • ********
  • Posts: 3,390
  • The MegaGlest Moder.
    • View Profile
Re: Forums moved to forum.megaglest.org
« Reply #13 on: 28 March 2013, 01:44:33 »
Everything looks like its working.  ;)
Get the Vbros': Packs 1, 2, 3, 4, and 5!