Author Topic: G3d exporter does not export textures..(texture ignored error)  (Read 1086 times)

Ingvarr23

  • Archer
  • *
  • Posts: 23
    • View Profile
Hello, I have learnt a bit of Blender and made a simple test model(textured) to export to Megaglest. However I run into this problem:
"first texture slot in first material isnt of type IMAGE or it is not unwrapped, texture ignored"
Any help would be appreciated.. Thanks in advance.. ( I need to know this in case I start some serious modelling(buildings, units etc))

titi_son

  • Draco Rider
  • *****
  • Posts: 283
  • titi_son
    • View Profile
I think you did not assign a material to your model. Take a look at the guides on our wiki https://docs.megaglest.org/Blender_Modelling#Guides
My first Tilseset: SPRING :) (included in Megaglest )

Secret Hint: To play online join the IRC #megaglest-lobby on freenode which is the lobby chat ingame. So you can chat with or wait for people in the lobby without running megaglest all the time.

Ingvarr23

  • Archer
  • *
  • Posts: 23
    • View Profile
Thank you for the link, I will take a look tomorrow.. I am still noob at this, but how is it possible that I have a completely textured model with no material assigned..?
Edit! I followed the instruction herehttps://docs.megaglest.org/Texture_material  as much as I could and now I can get it to export wihtout any error .
However I get a mesh colored in purple and orange without texture( no separate image file) I will link the g3d file if anyone is interested..
I also use GAE viewer because MG one is buggy for me.
https://mega.co.nz/#!EF9kHQZT!Ui7sG5si94l3GuqmJcMoSjUtCXwiprydULelgcqYiYo
« Last Edit: 17 June 2014, 12:23:19 by Ingvarr23 »

Elvas

  • Archer
  • *
  • Posts: 25
    • View Profile
lol this is an old topic ... i just looked around to find someone who had the same error, and fixed it, but as far as i can see, you didnt make it either :DDDDD
(if you did, tell me how O-o)

andy_5995

  • Moderator
  • Ornithopter
  • ********
  • Posts: 457
  • Debian Linux user
    • View Profile
    • Andy Alt's home page
Looks like no one responded to OP's last question, and it changed the topic of the thread. But this topic is so old gonna lock it now. Elvas created a fresh one at https://forum.megaglest.org/index.php?topic=10055.msg93853#msg93853
« Last Edit: 7 April 2019, 21:36:51 by andy_5995 »

 

anything